velikol.ru
1


3. Циклические (пока, для, до) алгоритмы. Создание блок-схем.

Задача1. В программе «Создание блок-схем», определите значение переменной a после выполнения фрагмента алгоритма.

Словесное описание алгоритма:

нц пока УСЛОВИЕ

ПОСЛЕДОВАТЕЛЬНОСТЬ КОМАНД

кц

Результат сохраните в своей папке под названием «Значение_а»


Задание:

1. Составьте аналогично блок-схему для алгоритма:

нач (описание переменных)

с:=1

b:=0

нц пока b<>4

b:=b+1

с:=с*2

кц

кон

В блок-схеме сделайте вывод результата для значения с.

Результат сохраните в своей папке под названием «Значение_с»


2. В тетради определите значение переменной n после выполнения фрагмента алгоритма.





4. Смешанные алгоритмы. Цикл и ветвление. Создание блок-схем.

Задание1. Создайте блок-схему и найдите x, y для х=5, у=10.

Словесное описание алгоритма:

нц пока y<=10

если x<=y

то x:=x+1; y:=y-1

иначе x:=x-5; y:=y+5

кц


Результат сохраните в своей папке

под названием «Значения_х_у»


Задание2. В тетради

определите значение переменной

X и У после выполнения

фрагмента алгоритма.